RE: Shadow Hotshoe-Adapter für Sony NEX-Kameras

#16 von hlenz , 29.11.2013 13:10

Ich habe von Elektronik keinen Schimmer, aber auch so einen Adapter hier (ob baugleich kann ich nicht sagen).
Der löst an meiner NEX5 alle Blitze aus, die ich darauf ausprobiert habe. Das sind allerdings keine Nikon, sondern Minolta-Modelle.
Da hierbei keine weiteren Kontakte als der Auslösekotakt und Masse benutzt werden, frage ich mich, wie ein Adapter da etwas erkennen können soll.
Falls ich da irgendwas testen kann, helfe ich gerne (bitte genaue Anleitung ).


Gruß

Harald


hlenz  
hlenz
Beiträge: 532
Registriert am: 20.05.2009


RE: Shadow Hotshoe-Adapter für Sony NEX-Kameras

#17 von matthiaspaul , 30.11.2013 04:15

ZITAT(ddd @ 2013-11-29, 12:10) Auf diesem Bild von Pete (Pin 1 ist links) sieht man, dass die Pins 13&14 über einen 4-Beiner gegen Pin 4 (REG_GND) gelegt sind. Dieser 4-Beiner ist ein 2xWiderstand, allerdings hat Pete leider den Wert nicht bestimmt. Um gegen die 100k runterzuziehen sind mglw. 470R nötig -OHNE GEWÄHR-. Schaltpläne der Blitze (egal ob HVL-F7S oder HVL-F20S) gibt es leider nicht. Ggfs. könntest Du Deinen HVL-F7S von der NEX öffnen und den 4-Beiner mal nachmessen (und uns die Werte mitteilen ).[/quote]
Dafür muß der S-Blitz noch nicht mal geöffnet werden, es reicht auch, mit den Meßspitzen eines Multimeters den Widerstand zwischen den Pins 13 und 4 (für ID1) bzw. Pins 14 und 4 (für ID2) des Konnektors am Blitz zu messen.

Gleiches gilt auch für M-Blitzgeräte, nur daß dort der Widerstand zwischen den Pins 1 und 7 (für ID3), 2 und 7 (für ID2) und 3 und 7 (für ID1) interessant ist.

Wer hat eine HVL-F7S, HVL-F20S, HVL-F20M, HVL-F43M oder HVL-F60M und kann mal nachmessen?

Wie groß die Pullups an den ID-Pins in der Kamera sind, kann man ebenfalls leicht von außen herausfinden, indem man mit einem hochohmigen Digitalmultimeter die Spannung an dem betreffenden ID-Pin in offenem Zustand mißt und den Pin dann über einen 10K-Widerstand auf GND zieht und zeitgleich die Spannung mißt, die an diesem 10K-Widerstand abfällt. Anhand dieses Spannungswertes kann man dann berechnen, welchen Wert der Pullup in der Kamera haben muß.

Viele Grüße,

Matthias


"All the important human advances that we know of since historical times began
have been due to individuals of whom the majority faced virulent public opposition."
--Bertrand Russell

http://www.mi-fo.de/forum/viewtopic.php?t=13448 (Minolta Forum Thread Index)


matthiaspaul  
matthiaspaul
Beiträge: 14.595
Registriert am: 08.06.2004


RE: Shadow Hotshoe-Adapter für Sony NEX-Kameras

#18 von ddd , 30.11.2013 15:24

moin, ZITAT(matthiaspaul @ 2013-11-30, 4:15) Dafür muß der S-Blitz noch nicht mal geöffnet werden, es reicht auch, mit den Meßspitzen eines Multimeters den Widerstand zwischen den Pins 13 und 4 (für ID1) bzw. Pins 14 und 4 (für ID2) des Konnektors am Blitz zu messen.[/quote]
manchmal sieht man den Wald vor Bäumen nicht ...
Und man sollte den Schaltplan komplett ansehen, nicht nur den Anchlussbereich: Wir sind bislang davon ausgegangen, dass die beiden (SAT/SAT2) bzw. drei (bei mi) ID-Pins digitale Eingänge sind, und damit "nur" drei bzw. sieben Geräte unterschieden werden könnten.

Falsch gedacht ... die ID-Pins hängen an AD-Wandler-Eingängen! D.h. die Werte der Widerstände sind wichtig, da wir die Auflösung der AD-Wandler nicht kennen. Sicher ist nur, dass "offene" Eingänge bedeuten: "kein Gerät angeschlossen".

Bei allen Kameras mit SAT (NEX-3, NEX-C3, NEX-5) und SAT2 (NEX-F3, NEX-5N, NEX-5R, NEX-5T) liegen die beiden ID-Eingänge mittels 100kΩ-Pullups an 3.15V. Diese Spannung ist sehr genau geregelt und bezogen auf REG_GND (am SAT/SAT2 an Pin 4). Da die Eingänge auf AD-Wandler geführt werden, müssen diese Werte bei allen Kameras gleich sein bzw. zu der Charakteristik der AD-Wandler passen.

Ich habe die Werte für den HVL-F7S (mit Spitzenkontakten unter der Lupe ist es immer noch fummelig), gemessen wird gegen Pin 4 (REG_GND), dem Bezugspotential der AD-Wandler:
SAT/SAT2-GerätKategorieID1 Pin13ID2 Pin14keineskeine∞∞HVL-F7SBlitz22kΩ22kΩHVL-F20SBlitzFA-EX1SBlitz-Verlängerung1:11:1FDA-EV1SSucherFDA-SV1 (optisch)Sucher∞∞ECM-SST1Mikrofon
Wenn weitere Infos eintrudeln, trage ich die hier nach. Ich habe keine weiteren SAT/SAT2-Geräte und kann daher nix messen. Sind das alle SAT/SAT2-Geräte?

ZITAT(matthiaspaul @ 2013-11-30, 4:15) Gleiches gilt auch für M-Blitzgeräte, nur daß dort der Widerstand zwischen den Pins 1 und 7 (für ID3), 2 und 7 (für ID2) und 3 und 7 (für ID1) interessant ist.
Wer hat eine HVL-F7S, HVL-F20S, HVL-F20M, HVL-F43M oder HVL-F60M und kann mal nachmessen?[/quote]
HVL-F20M im Haus, HVL-F43M im Zulauf. Sollten wir deren Werte in diesem thread "verstecken" oder ist es sinnvoll, dies in einen passend benannten thread auszulagern, damit diese Infos besser gefunden werden können? Gern auch mit den SAT/SAT2-Werte zusammen.

ZITAT(matthiaspaul @ 2013-11-30, 4:15) Wie groß die Pullups an den ID-Pins in der Kamera sind, kann man ebenfalls leicht von außen herausfinden, [...][/quote]
nicht nötig, ich habe die Werte Sie sind bei allen Kameras mit mi-Schuh 100kΩ an 3.15V gegen REG_GND.

btt: Das Problem des Themenerstellers liegt aber mglw. wo anders:
- Ist der Adapter funktionsfähig? Eventuell ist der Transistor defekt oder dessen Übergangswiderstand ist zu groß, um den angeschlossenen Blitz auszulösen.

- steuert die NEX das Signal immer an oder nur, wenn ein Blitz erkannt wird? (A900 z.B. feuert immer)
- steuert die NEX das Signal immer an oder nur, wenn die Blitzsynchronzeit nicht überschritten wird? (A900 z.B. feuert immer)
- steuert die NEX das Signal bei Blitzerkennung immer an oder nur, wenn Blitzbereitschaft erkannt wird? Dann müsste das komplette SIO-Protokoll auf F2/F3 gefahren werden ... (A900 z.B. feuert immer)
- steuert die NEX das Signal nur an, wenn "Blitz aktiv" oder deaktiviert sie es nur bei "Blitz deaktiveren"? (A900 z.B. deaktivert nur ausdrücklich)

Bei den (D)SLR/SLT ist es so, dass der Kontakt F1 wie ein klassischer Kurzschlussschalter bedient wird, d.h. immer bei Beginn (oder Ende wenn 2.Vorhang) der Belichtung wird F1 gegen GND über einen Transistor kurzgeschlossen, egal was eingestellt ist. Nur bei "Blitz deaktivieren" wird der Transistor nicht durchgesteuert. Da die NEX (weitgehend) dieselbe Hardware und Software verwenden (auch wenn es von aussen nicht so aussieht ) gehe ich von gleichartigem Verhalten aus. Wäre dies anders, könnten die "no-name"-Adapter nicht funktionieren.

@TO: hast Du einen 2. Blitz, den Du ausprobieren könntest? Möglichst einen Blitz eines anderen Herstellers, ich kenne die Eigenschaften des Nikon-Blitzprotokolls nicht und ob dort das Problem liegt.

-thomas

edit: FA-EX1S nachgetragen


wieder da ...


ddd  
ddd
Beiträge: 506
Registriert am: 19.11.2009


RE: Shadow Hotshoe-Adapter für Sony NEX-Kameras

#19 von matthiaspaul , 30.11.2013 15:59

ZITAT(ddd @ 2013-11-30, 15:24) Wenn weitere Infos eintrudeln, trage ich die hier nach. Ich habe keine weiteren SAT7SAT2-Geräte und kann daher nix messen. Sind das alle SAT/SAT2-Geräte?[/quote]
Mir fällt auch nichts weiter ein, außer vielleicht der Extender FA-EX1S (A-1787-305-A), aber der wird vermutlich alle Signale nur 1:1 durchreichen.

Viele Grüße,

Matthias


"All the important human advances that we know of since historical times began
have been due to individuals of whom the majority faced virulent public opposition."
--Bertrand Russell

http://www.mi-fo.de/forum/viewtopic.php?t=13448 (Minolta Forum Thread Index)


matthiaspaul  
matthiaspaul
Beiträge: 14.595
Registriert am: 08.06.2004


RE: Shadow Hotshoe-Adapter für Sony NEX-Kameras

#20 von ddd , 30.11.2013 20:27

moin, ZITAT(matthiaspaul @ 2013-11-30, 15:59) Extender FA-EX1S (A-1787-305-A), aber der wird vermutlich alle Signale nur 1:1 durchreichen.[/quote]
fast. Ich habe meinen aufgemacht und nachgesehen: das Flexi enthält einen Halbleiter, wird eine Dual-ESD-Diode sein, welche die ID-Pins gegen Frame schützt.
Es sind nicht alle Signale durchverbunden, nur die Pins 1-7,13,14,15(FG).
Es sind die Signale F0(GND-Pin4), F1(Strobe-Pin5), F2(SIO-Pin3), F3(SCLK-Pin2), Vdd (3.15V-Pin7), UnregBatt+(Pin1,Fuse1.4/1.6A), BattGNd (Pin6), ID1(Pin13), ID2(Pin14) und FrameGnd (Pin15/Frame) bestückt.

Hier die beschrifteten Makro-Fotos des Flexis, oben der Kamerastecker, unten die Gerätebuchse:
[attachment=13182:FA_EX1S_Flexi.jpg]
Oben ergänzt ...

-thomas

edit: Signal-Pin ergänzt


wieder da ...

Angefügte Bilder:
Aufgrund eingeschränkter Benutzerrechte werden nur die Namen der Dateianhänge angezeigt Jetzt anmelden!
 f272t31749p300938n1.jpg 

ddd  
ddd
Beiträge: 506
Registriert am: 19.11.2009


RE: Shadow Hotshoe-Adapter für Sony NEX-Kameras

#21 von geithman ( gelöscht ) , 02.12.2013 18:27

ZITAT(hlenz @ 2013-11-29, 13:10) Ich habe von Elektronik keinen Schimmer, aber auch so einen Adapter hier (ob baugleich kann ich nicht sagen).
Der löst an meiner NEX5 alle Blitze aus, die ich darauf ausprobiert habe.[/quote]
Inzwischen bin ich mir sicher, dass die NEX-5 (und die 3N) da anders reagiert als die NEX-3:
Wann immer ich Berichte zu funktionierenden Adaptern gefunden habe, dann immer bei einer Nex-5 oder einer Nex-3N ...

ZITAT(hlenz @ 2013-11-29, 13:10) Das sind allerdings keine Nikon, sondern Minolta-Modelle.[/quote]
Ich habe auch keinen Nikon-Blitz sondern einen "Multiblitz". Der hat nur einen kleinen runden Kontakt, so wie das ganz früher (noch vor Hotshoe-Zeiten) üblich war ...


geithman

RE: Shadow Hotshoe-Adapter für Sony NEX-Kameras

#22 von geithman ( gelöscht ) , 02.12.2013 18:34

ZITAT(hlenz @ 2013-11-29, 13:10) Der löst an meiner NEX5 alle Blitze aus, die ich darauf ausprobiert habe.[/quote]
Musst Du dazu den Blitz aktivieren (also über die Taste auf der 4-Wege Wippe) oder blitzt der - wenn angeschlossen und eingeschaltet - IMMER mit?


geithman

RE: Shadow Hotshoe-Adapter für Sony NEX-Kameras

#23 von geithman ( gelöscht ) , 02.12.2013 18:45

ZITAT(ddd @ 2013-11-30, 15:24) Ist der Adapter funktionsfähig? Eventuell ist der Transistor defekt oder dessen Übergangswiderstand ist zu groß, um den angeschlossenen Blitz auszulösen.[/quote]
Ob der Adapter überhaupt funktioniert, kann ich leider nicht sagen:
- Ich habe noch einen etwa 20 Jahre alte kleinen Osram-Blitz, den ich schon mal direkt aufgesteckt habe: der blitzt nicht; auf einer Nikon-DSLR blitzt er; Blitz ist also prinzipiell OK.
- Ich hatte noch einen weiteren Blitzadapter, nämlich eine Funk-Verbindung (Sender auf die NEX, Empfänger an den Blitz) und der hat auch nicht funktioniert; weder mit dem Osram noch mit dem Multiblitz.
Deswegen weiß ich nicht, ob der Adapter nicht defekt ist oder einfach nur mit meinen Blitzen nicht zurecht kommt.
Ich sehe schon, ich muss mal jemanden finden, der eine NEX-5 mit funktionierendem Adapter hat und dann dort meinen Adapter ausprobieren.

Ob der Übergangswiderstand für den Blitz zu hoch ist, weiß ich auch nicht... wie kann man das herausbekommen?
Ich kann ja kein Multimeter für eine Widerstandsmessung anklemmen - der Kontakt wird ja nur so kurz geschlossen, dass man da vermutlich nichts sehen wird...
Ich habe leider auch keinen Schaltplan des Multiblitz, aber da der noch aus der Analog-Zeit stammt, könnte es sein, dass da die volle Blitzspannung auf dem Kontakt liegt - das wäre dann vermutlich ein Problem für den Transistor?

Herzliche Grüße aus Würzburg,
Stefan


geithman

RE: Shadow Hotshoe-Adapter für Sony NEX-Kameras

#24 von matthiaspaul , 02.12.2013 19:45

ZITAT(geithman @ 2013-12-02, 18:45) Ob der Übergangswiderstand für den Blitz zu hoch ist, weiß ich auch nicht... wie kann man das herausbekommen?
Ich kann ja kein Multimeter für eine Widerstandsmessung anklemmen - der Kontakt wird ja nur so kurz geschlossen, dass man da vermutlich nichts sehen wird...[/quote]
Ja, das würde man nur auf einem Oszilloskop sehen.

Aber neben einem zu hohen Übergangswiderstand könnte es auch an einer zu geringen Zündkreisspannung liegen. Die kann nicht nur zu hoch sein (bei alten Blitzgeräten mit Hochvoltzündkreis), sondern auch zu niedrig. Dann arbeitet der den Stromkreis schließende Transistor in der Kamera, der ja über diese Spannung versorgt wird, nicht mehr richtig. In der Praxis kann man sagen, daß die Spannung nicht kleiner als 1,5V sein sollte, aber eben auch nicht mehr als ca. 4,5V.
ZITATIch habe leider auch keinen Schaltplan des Multiblitz, aber da der noch aus der Analog-Zeit stammt, könnte es sein, dass da die volle Blitzspannung auf dem Kontakt liegt - das wäre dann vermutlich ein Problem für den Transistor?[/quote]
Je nachdem, wie hoch die Zündkreisspannung ist, wird das irgendwann zum Problem, ja. Pauschal kann man sagen, daß alles oberhalb von 4,5V potentiell gefährlich ist, wobei es Kameras gibt, die wirklich nicht mehr vertragen, solche, die selbst noch ein paar Schutzelemente enthalten und in Grenzen höhere Spannungen vertragen (solange nicht gleichzeitig viel Strom geliefert wird) und solche, die problemlos mit Zündkreisspannungen von mehreren hundert Volt klarkommen.

Die Zündkreisspannung Deines Blitzgerätes kannst Du ganz einfach mit Deinem Multimeter messen, indem Du bei voll aufgelademen und eingeschalteten Blitz die Spannung zwischen Mittenkontakt (bzw. dem dazu äquivalenten Pin) und Masse am Blitzfuß mißt.

Viele Grüße,

Matthias


"All the important human advances that we know of since historical times began
have been due to individuals of whom the majority faced virulent public opposition."
--Bertrand Russell

http://www.mi-fo.de/forum/viewtopic.php?t=13448 (Minolta Forum Thread Index)


matthiaspaul  
matthiaspaul
Beiträge: 14.595
Registriert am: 08.06.2004


   

Clearviewer: NEX mit Sucher
NEX-VG900 für 1599¤ im Sony Outlet Store

  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
| 2002- © so-fo.de | minolta-forum.de |
Xobor Einfach ein eigenes Forum erstellen